Volkswagen Touareg Forum banner

1 - 13 of 13 Posts

·
Member
Joined
·
75 Posts
Discussion Starter · #1 ·
My touareg has diagnosed a Headlight Range Control Error, however when i took it to Martins they said it was linked to air suspension - -which mine doesnt have and Ridgeway say its a common error on Xenons - which is also disputed by Martins!

anyway, does anyone here know or have they experienced the same. I have had the vehicle undergo full diagnostics at the garage but they cant always get the error to "appear" or locate it after the event on the error log.

any suggestions would be gratefully received.

many thanks
 

·
Registered
Joined
·
876 Posts
Hi the headlamp range control can be affected by several things
1. the sensor in the lamp assembly
2. Again an old gremlin.. the condition of the battery
the battery is the most likely unless the battery has been replaced.
The last possibility is some damage to the lamp assembly although water ingress can have a similar effect.
 

·
Registered
Joined
·
876 Posts
Just came across this....." the controller for the headlamps which is J519 central electrical controller, part number 7L6 937 049 M with internal software status 3001. What made the troubleshooting very difficult is that this controller did not give any fault code."

This diagnosis would also point to a software bug but it is problematic as to its true problem. However a stab in the dark is better than none..
 

·
Registered
Joined
·
876 Posts
You could try to get the garage to swap the controller with another Treg to see if that proved anything....
 

·
Senior Member
Joined
·
202 Posts
Do you only get the fault code after it has been parked on your driveway?

I too get this occasionally -but only on my sloping driveway after its been parked up nose down overnight. I think the xenons are compensating for the angle. I never get it when parked on a hill for say an hour or two though. :roll:

W
 

·
Registered
Joined
·
1 Posts
Hi
J 519 is behind the dash and not to easy to remove!
Every time i see this fault its alway a level sensor.vehicle may not have air suspension but headlights need to know were level is.any load in the rear auto adjusts the headlamps.my bets on a rear level sensor or wiring to it.it usually kicks off after vehicle being in water.!!!
 

·
Member
Joined
·
75 Posts
Discussion Starter · #8 ·
Hi all,

this error literally appeared from nowhere, i park on my driveway which is almost level - it has only a slight gradient. It has been parked on said driveway since i bought the touareg back in 04. But it also errors when i have parked on an incline. The wierd thing is that the dealer could replicate the error first time but when it was booked in for a full diagnostic they couldnt find it!

i have booked it in again next week as my tv tuner has gone on the blink too. i am hoping it should be covered by warranty as the original dealer i bought from had apparently wired in the nokia cradle incorrectly which caused wires to melt on the tv tuner which caused it to fail. The wierd thing is that the cradle was installed on day 1, 0 miles, and the tv tuner has only just failed nearly 3 years on!

so fingers crossed as i dont fancy a big "fight" as to who has to pay - the way i see it is that as VW did it, and the car is still in the same condition as i bought it, that its down to them! let's hope they feel the same.
 

·
Registered
Joined
·
4 Posts
Hi,

I have just got the same problem as described in this topic. The headlight range control warning goes on several times when I' driving the car. The local dealer have found an error code for the level sensor and replaced the sensor. (positioned close to the left frontwheel). This replacement had no effect. According to the dealer, this sensor was also replaced one year ago (before I bought the car). Currently, the dealer have issued a request for information the the factory in Germany. I expect to receive some feedback next week. In the meantime - any advises on how to proceed are highly appreciated.
 

·
Registered
Joined
·
1 Posts
Hi - I had this problem and have just had it fixed, the dealership took 2 days to find out what the problem was, it was apparently caused by a faulty sensor. Thankfully it was still under warranty. If you want me to find out the part number of what they replaced let me know.
 

·
Chairman
Joined
·
19,917 Posts
Cowboys23 said:
Hi - I had this problem and have just had it fixed, the dealership took 2 days to find out what the problem was, it was apparently caused by a faulty sensor. Thankfully it was still under warranty. If you want me to find out the part number of what they replaced let me know.
Could you please post the number anyway for others who may find this thread useful in the future? Thank you.
 

·
Registered
Joined
·
2 Posts
2006 V8 T-reg. 34K miles. I have delt with this prob for entirely too long. Going back to dealer once again on 6/26/09. Sensors have been replaced 3-4 times, Wire harness replaced 3 times, Harness cleaned every time. Total trips to dealer... 7 TIMES! Same problem. Any ideas to help before I research 'Lemon Law'

Despite this I do love the vehicle and fully intend to get this worked out provding I maintain my sanity.

Gary

darrenasmith said:
My touareg has diagnosed a Headlight Range Control Error, however when i took it to Martins they said it was linked to air suspension - -which mine doesnt have and Ridgeway say its a common error on Xenons - which is also disputed by Martins!

anyway, does anyone here know or have they experienced the same. I have had the vehicle undergo full diagnostics at the garage but they cant always get the error to "appear" or locate it after the event on the error log.

any suggestions would be gratefully received.

many thanks
 
1 - 13 of 13 Posts
Top